[WordPress] GAE 1.9.18 SDK に FTP の資格情報を要求するワードプレスのプラグインを更新

スポンサーリンク

質問

GAE の私のローカル サーバーで実行されているワードプレスのプラグインを更新しようとしているが、FTP の資格情報を入力するプロンプトが表示を得ることです。AppEngine 1.9.17 から変わった唯一の事は、アップグレード 1.9.18 を SDK。誰が解決するのにはどのようですか?

答え

ワードプレス ワードプレスのファイルとフォルダーを書き込むためのアクセス許可が正しく設定されていない場合、FTP の資格情報を要求します。これは、ことができます発生する PHP によって apache ユーザー (mod_php や CGI として実行されている WordPress のファイルを所有するユーザーではなく。アップグレードの wp-コンテンツのアクセス許可が変更されました可能性があります。 http://codex.wordpress.org/Changing_File_Permissions を参照してください

回避 wp-config.php に直接 FTP の資格情報を配置するには。 http://codex.wordpress.org/Editing_wp-config.php#WordPress _Upgrade_Constants を参照してください

define( 'FTP_USER', 'username' );
define( 'FTP_PASS', 'password' );
define( 'FTP_HOST', 'ftp.example.org:21' );

http://stackoverflow.com/questions/28891428/updating-wordpress-plugins-asks-for-ftp-credentials-with-gae-1-9-18-sdk

スポンサーリンク

Leave a Reply