[WordPress] WP – キュー スクリプトの難しさ

スポンサーリンク

Question

私は

wp_enqueue_script

と javascript ファイルを追加しようとしています。スクリプトはロードされないように見えるすべてのページで。何をしてです::

function uberpasscode_scripts() {
    wp_enqueue_script( 'bootstrap', get_template_directory_uri() . "/assets/js/bootstrap.min", array('jquery'));
    wp_enqueue_script( 'jquery', get_template_directory_uri() . "/assets/js/jquery-1.11.1.min" );
}

add_action( 'wp_enqueue_scripts', 'uberpasscode_scripts' );

答え

これは javascript (js) 拡張子の後に不足しているためにです分

function uberpasscode_scripts() {
    wp_enqueue_script( 'bootstrap', get_template_directory_uri() . "/assets/js/bootstrap.min.js", array('jquery'),'', true );
    wp_enqueue_script('jquery');
}

add_action( 'wp_enqueue_scripts', 'uberpasscode_scripts' );

これら 2 つのパラメーターを追加してみてください。また、そのバージョンをロードしようとしては、jQuery がブートス トラップの古すぎます。ワードプレスに組み込まれている jQuery を使用します。また、

functions.php

にこれを入れていることを確認してください

http://stackoverflow.com/questions/27726999/wp-difficulty-with-enqueueing-scripts

スポンサーリンク

Leave a Reply